Is it true that in Drupal you can only overwrite core functions that start with ‘theme_’?

Is it true that in #Drupal you can only overwrite core functions that start with ‘theme_’? Wouldn’t want to hack the core…